The ARCore dependency minimum version code com.google.ar.core.min_apk_version is missing from the AndroidManifest.xml file although the meta-data tag com.google.ar.core has been specified.

Problem :

The ARCore dependency minimum version code com.google.ar.core.min_apk_version is missing from the AndroidManifest.xml file although the meta-data tag com.google.ar.core has been specified.

 

Solution :

This is Unity ARCode dependency problem.

just add this line in menifest

  <meta-data android:name=”com.google.ar.core.min_apk_version” android:value=”24″ />

[java]<application

android:icon="@drawable/app_icon"

android:label="@string/app_name"

android:theme="@android:style/Theme.NoTitleBar.Fullscreen"

android:debuggable="false">

<meta-data android:name="com.google.ar.core.min_apk_version" android:value="24" />

<activity android:name="com.unity3d.player.UnityPlayerNativeActivity"

android:label="@string/app_name">

<intent-filter>

<action android:name="android.intent.action.MAIN" />

<category android:name="android.intent.category.LAUNCHER" />

</intent-filter>

<meta-data android:name="unityplayer.UnityActivity" android:value="true" />

<meta-data android:name="unityplayer.ForwardNativeEventsToDalvik" android:value="false" />

</activity>

<uses-library android:name="com.osterhoutgroup.api.ext" android:required="false" />

</application>

[/java]

Leave a Reply

Your email address will not be published. Required fields are marked *